Hob displays error message E9
Issue
- The hob is showing an error message E9
Applies to:
- electric (ceramic) hob
- induction hob
Resolution
1. Disconnect the appliance from the power for at least 30 seconds.
Reconnect it and switch it back on.
Note: To restart the appliance, you need to switch it off from the mains and wait at least 30 seconds before switching it back on.
For built-in appliances, because you can't disconnect them from the electricity supply, you'll have to turn them off at the RCD switch.
2. Contact an Authorised Service Centre.
If the above advice does not resolve the problem, we recommend requesting a visit from a service engineer.
Make a note of the reported error code and quote it when you request an engineer. This will not solve your problem, but it will help our engineer identify the cause of the problem.
Cause:
Error code E9 indicates a fault in the electronic module
Was this article helpful?
Related Articles
- What cookware is suitable for cooking zones with induction heating?
- Hot plate switches itself off / beeps
- Hob blows/ trips fuse
- How to use the FlexiBridge function on your Electrolux induction hob
- My hob does not turn on
- How to use the child lock and lock function on your Electrolux induction hob
- How to use the frying function on your Electrolux SenseFry hob
- How to use the SenseBoil® function on your Electrolux hob
- Hob displays error message E4 / E401 / E402 / E403 / E421 / E422 / E423 / E431 / E432 / E433
- How to cook with your Electrolux TotalFlex induction hob
Spare parts & Accessories
Find original spare parts for your appliance in our webshop and have them delivered directly to your door.
Book a service
Having issues with your appliance? Book a reliable and professional service from our expert technicians to get your product up and running.